Sunday, February 24, 2008

Youtube not reachable, temporarily

Youtube stopped opening around 23:19, February 24th.

At first I thought QualityNet has blocked Youtube, but they have no reason to. Further investigation showed that we got affected due to Pakistan blocking Youtube, and since we go through Pakistan, we got blocked as well.

Here's a traceroute of whole thing from QualityNet:
mj@mj-evil-station:~$ traceroute youtube.com
traceroute: Warning: youtube.com has multiple addresses; using 208.65.153.238
traceroute to youtube.com (208.65.153.238), 30 hops max, 40 byte packets
1 dsldevice.lan (192.168.1.254) 81.140 ms 89.402 ms 100.769 ms
2 62.150.109.1 (62.150.109.1) 199.651 ms 206.459 ms 261.711 ms
3 rb02-internet.qualitynet.net (62.150.93.233) 371.742 ms 317.482 ms 353.407 ms
4 jun-skb.qualitynet.net (62.150.200.5) 320.456 ms 225.162 ms 248.510 ms
5 195.229.27.29 (195.229.27.29) 188.310 ms 298.991 ms 432.766 ms
6 auh-emix-rb.emix.net.ae (195.229.31.3) 469.257 ms 299.604 ms 362.735 ms
7 dxb-r2-ether-1-0-0.emix.net.ae (195.229.0.98) 406.317 ms 195.229.0.126 (195.229.0.126) 196.553 ms dxb-r2-ether-1-0-0.emix.net.ae (195.229.0.98) 269.163 ms
8 195.229.0.181 (195.229.0.181) 355.469 ms 225.016 ms 226.647 ms
9 pos2-0.ar01.hkg04.pccwbtn.net (63.218.61.137) 582.209 ms 514.871 ms pos2-1
.ar01.hkg04.pccwbtn.net (63.218.61.141) 550.151 ms
10 pos1-0.cr02.hkg04.pccwbtn.net (63.218.114.66) 392.507 ms 417.320 ms 373.513 ms
11 * * *
12 * * *
13 * * *
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *
23 * * *
24 * * *
25 youtube.com.hk (208.65.153.238) 520.823 ms 418.294 ms 431.483 ms

mj@mj-evil-station:~$ traceroute 208.65.153.238
traceroute to 208.65.153.238 (208.65.153.238), 30 hops max, 40 byte packets
1 dsldevice.lan (192.168.1.254) 45.403 ms 95.449 ms 99.379 ms
2 62.150.109.1 (62.150.109.1) 179.348 ms 368.496 ms 342.110 ms
3 rb02-internet.qualitynet.net (62.150.93.233) 369.112 ms 348.417 ms 253.605 ms
4 jun-skb.qualitynet.net (62.150.200.5) 163.947 ms 367.323 ms 245.216 ms
5 if-8-4.bb1.RSD-Riyad.teleglobe.net (66.198.126.45) 155.793 ms 41.123 ms 42.489 ms
6 if-6-0.bb1.JSD-Jeddah.teleglobe.net (195.219.153.25) 48.791 ms 50.982 ms 103.248 ms
7 if-11-0.mcore3.NJY-Newark.teleglobe.net (216.6.57.49) 430.598 ms 528.746 ms 583.103 ms
8 if-2-0.core1.NTO-NewYork.teleglobe.net (216.6.57.66) 448.712 ms 545.164 ms 423.040 ms
9 14.icore1.NTO-NewYork.teleglobe.net (216.6.82.2) 377.902 ms 403.390 ms 472.671 ms
10 209.58.26.30 (209.58.26.30) 575.457 ms 331.368 ms 379.346 ms
11 YOUTUBE-LLC.po1.401.ar2.SJC2.gblx.net (64.212.108.162) 645.748 ms 437.855 ms 420.526 ms
12 youtube.com.hk (208.65.153.238) 697.133 ms 447.682 ms 590.483 ms


From the above, you can see that the first attempt had a lot of unreachable hops, but they passed through the second time. This happened because I was attempting traceroute the first time while the routes to youtube were being cut/changed. The time between the 2 attempts was less than 10 minutes.

While writing this post, youtube seemed to work again. Some say it's not loading fully or some functions are not working.

Just checked from a FastTelco user, who was unable to view youtube at all. Here's a traceroute:
Tracing route to youtube.com [208.65.153.251]
over a maximum of 30 hops:

1 1 ms 1 ms 1 ms 192.168.1.1
2 724 ms 724 ms 716 ms 89.203.7.254
3 670 ms 682 ms 786 ms tec-core-so32.fasttelco.net [62.215.0.94]
4 696 ms 752 ms 971 ms 62.215.0.57
5 997 ms 748 ms 422 ms 78.159.161.9
6 463 ms 192 ms 125 ms 195.229.29.133
7 143 ms 73 ms 132 ms dxb-emix-ra.ge1302.emix.ae [195.229.31.67]
8 117 ms 100 ms 77 ms 195.229.0.181
9 245 ms 246 ms 386 ms t2a6-p5-3.uk-lon2.eu.bt.net [166.49.160.161]
10 281 ms 267 ms 250 ms t2c1-ge7-0.uk-lon2.eu.bt.net [166.49.176.43]
11 374 ms 321 ms 249 ms t2c1-p3-0.uk-glo.eu.bt.net [166.49.208.98]
12 250 ms 250 ms 244 ms t2c1-p9-1.uk-eal.eu.bt.net [166.49.208.125]
13 275 ms 271 ms 265 ms t2c1-p5-0-0.us-ash.eu.bt.net [166.49.164.65]
14 * * * Request timed out.
15 * 292 ms 260 ms 10.33.112.70
16 300 ms 272 ms 317 ms 10.33.254.141
17 379 ms 399 ms 378 ms 10.33.254.117
18 503 ms 388 ms 510 ms 10.33.176.114
19 383 ms 337 ms 330 ms youtube.com.hk [208.65.153.251]


More details on the ban from ZDNet.

2 comments:

Nosayba said...

Huh..The time for a packet going through Qualitynet averaged to 578 ms, while for FT the average is 350 ms..?

Maybe it's the switching routes thing you mentioned. Anyways, I'm using FT and Youtube is working fine now.

MBH said...

Take a look at the traceroute from QualityNet & from FT. The difference is that QNet goes through TeleGlobe which is in KSA, while FT goes through EMIX which is in UAE.

TeleGlobe is a congested line, which causes high latency values.